"Schnittstelle nicht gefunden" - eine Beziehungskriese

Hier gibt es Fachwissen auch ohne Experimentierkästen

"Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon ChrisH » 4. Mär 2012, 19:39

Hallo ins Forum, ich fange mal einfach von vorne (also eher von Hinten...) aus an:

1993: KOSMOS bringt den "XN HiTec + PC-Interface" Aufrüstkasten heraus, der den XN2000 auf den Stand eines XN3000 und einem PC-Interface aufwertet. Wohl kurze Zeit später gab es den ganzen Kasten dann auch komplett als "HiTec + PC Interface" - die Oberstufe der XN-Reihe. Mit diesem Experiemntierkasten konnte man grafische Messwerte am PC-Bildschirm darstellen. Schöne Anzeigen und vielfältige Messgeräte und Möglichkeiten machten ein Experimentieren wie im Labor möglich. Nicht zu vergssen: zu der Zeit war ein 486/33 mit Windows 3.1 standard (wie man auch schön am Katalog von 1993 erkennen kann). Das Experimentiervolk von damals mag wohl hoch zufrieden gewesen sein...

1996: Die Zeiten wandeln sich und die Neuerungen im PC-Bereich schreiten schnell voran. Der Pentium steht bereit und Windows 95 wird neuer Masstab am PC. Die PC-Strukturen ändern sich und KOSMOS beginnt, die Schnittstellenplatinen zu modifizieren. Anfangs wurden die Platinen ausgetauscht, später vom KOSMOS-Service selbst umgerüstet. So half man den Usern, die noch mit diesen Kästen experiementierten. Der HiTec+PC wurde aus gutem Grunde aus dem Programm genommen - zu schnell war der Fortschritt an dem Kasten vorbeigezogen...

2003: in einem Posting aus dieser Zeit entdeckte ich beim Googeln interessante Zeilen - jemand hat so einen Kasten in Betrieb genommen - jedoch gibt es mit der Schnittstelle (Erkennung) Probleme. Mehrere Threads verlaufen im Sande, Handbücher und Software werden angeboten aber irgendwie läuft es nicht...

2006: wieder einen Thread gefunden - viele Leute haben keinen Erfolg aber bei einem läuft es unter WIN XP. Na das lässt doch hoffen, zumahl er sogar eine (recht unvollständige) Anleitung mit ins Posting packt. Also muss es doch irgendwie gehen...

2012: und wieder einen Thread im Baukastenforum gefunden, wo doch so ein Unbeirrbarer fast 20 Jahre nach Erscheinen des XN HiTec PC versucht, einen solchen Kasten zum Laufen zu bringen. Die magere Google-Suche von zwei Wochen, die perfekt überarbeiteten Schnittstellen (2 Stück!), neues Handbuch und letzter Softwarestand von KOSMOS am Tisch liegend. Also zwei Schnittstellen, zwei Kabel, zwei verschiedene Computer und drei Betriebssysteme (darunter ein original WIN 3.11) dazu etwa 20 Stunden Software laden, löschen, Treiber installieren, wieder löschen, umstecken, anschliessen, abtrennen, ect.... Nun, was wollt Ihr hören? Ne Freunde - geht leider nicht! "Achtung: KOSMOS-Schnittstelle nicht gefunden".

FAZIT: ich bekomme das Gefühl, dass es sich um einen Hardwarefehler handelt und die Schnittstelle definitiv nicht zum Laufen zu bringen ist. Zudem fehlen leider Angaben zum Aufbau der Schnittstelle, Angaben zur Software und viele Hintergrundinformationen Seitens KOSMOS. Die Installationsanleitung von 1993 besagt gerade einmal, dass man die Schnittstelle anstecken muss und dann die Software installieren soll. Es ist überhaupt kein Basiswissen dazu vorhanden. Brauchte man damals ja auch nicht ;-). Entgegen der KOSMOS-Anleitung, wonach die KosmoLab-Software nur läuft, wenn die Schnittstelle aktiviert ist muss ich sagen: sie läuft immer (natürlich ohne etwas anzuzeigen)! Die Portozuweisungen und Porttreiber arbeiten einwandfrei - auf beiden PCs und unter allen drei Windows-Versionen. Gut, habe den Kasten nun weggepackt und alles auf Eis gelegt. Wir können in diesem Thread hier gerne Ideen sammeln und irgendwann mal auswerten oder ausprobieren. Aufgeschoben ist nicht aufgehoben.

Grüße, ChrisH

...wenigstens ein paar Bilder für Euch der KosmoLab-Software unter WINDOWS DREIPUNKTELF:

Bild
Bild
Benutzeravatar
ChrisH
 
Beiträge: 430
Registriert: 2. Feb 2011, 19:18
Wohnort: Velden/Vils

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon meiseAC » 4. Mär 2012, 19:56

Hallo ChrisH

Die Verbindung läuft ja über die alte LPT1 Druckerschnittstelle.
Ich nehme an das bei dir folgende Vorraussetzungen erfüllt sind:

LPT1 Schnittstelle am PC vorhanden, Im Bios aktiviert, im Bios mitz den Standardwerten versehen und im Gerätemanager (oder wie auch immer das bei Win 3.11 hieß als vorhanden und aktiviert angezeigt.
Schnittstellenkabel vorhanden und zwar in voller Belegung und in Ordnung?

Soweit alles OK?

viele Grüße

Rolf
Kosmos Spiele mit Radio, Kosmos Elektronik Junior, Kosmos Radio Elektronik 100, Kosmos Radio Elektronik 101, Kosmos Ü3, Kosmos XN3000, Kosmos Elektronik Profi, Schuco Profi Lab
Benutzeravatar
meiseAC
 
Beiträge: 363
Registriert: 25. Mär 2010, 12:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon ChrisH » 4. Mär 2012, 20:14

Hallo Rolf,

...ja das ist soweit alles klar, habe mich da auch erst mal durchgewurschtelt. Unter XP und WIN98 dann mit Userport.sys gearbeitet und die Einstellungen vom Gerätemanager übernommen, das passte auch. Zwei verschiedene Seriellkabel und beide voll belegt. Darum denke ich auch an einen generellen Hardware-Bug und nicht einen "Softwarefehler" wie in einem anderen Forum vor ein paar Jahren vermutet wurde. Auch wenn es rätselhaft ist, das die Software startet obwohl keine Schnitttstelle verfügbar ist *gg*.

ratlose Grüße, ChrisH
Benutzeravatar
ChrisH
 
Beiträge: 430
Registriert: 2. Feb 2011, 19:18
Wohnort: Velden/Vils

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon meiseAC » 4. Mär 2012, 20:43

OK, aber was sagt den Kosmos dazu?

Ich hatte deine Beiträge dahingehend verstanden das Kosmos Umbauten für Win95 gemacht hat. Nun schreibst du aber selbst unter 3.11 geht es nicht?
Was aber klar sein sollte da deine beiden Schnittstellen nun umgebaut sind???
Bin gerade etwas verwirrt.
Kannst du das nochmal aufrollen?

viele Grüße

Rolf
Kosmos Spiele mit Radio, Kosmos Elektronik Junior, Kosmos Radio Elektronik 100, Kosmos Radio Elektronik 101, Kosmos Ü3, Kosmos XN3000, Kosmos Elektronik Profi, Schuco Profi Lab
Benutzeravatar
meiseAC
 
Beiträge: 363
Registriert: 25. Mär 2010, 12:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon ChrisH » 4. Mär 2012, 20:48

Hallo Rolf,

die Modifikationen an den Schnittstellen beziehen sich nicht auf die Software, sondern auf die nachfolgende Hardware. Also damals wie die ersten Pentium-Rechner rauskamen und sich die Boardarchitektur wohl auch änderte (von 16 auf 32-bit?). Klar, die Betriebssysteme wuchsen dann auch dementsprechend. Es ist wie mit dem Huhn und dem Ei: was war zuerst da? Der neue Prozessor oder das neue Betriebssystem :D

irgendwie so. Grüße, ChrisH

PS: hätte ich noch einen Intel 486-Rechner gehabt, würde ich die Schnitttstellen natürlich erst ohne Umbau testen :-)
Benutzeravatar
ChrisH
 
Beiträge: 430
Registriert: 2. Feb 2011, 19:18
Wohnort: Velden/Vils

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon meiseAC » 4. Mär 2012, 21:16

Sorry liegt bestimmt an mir weil ich heute Abend zu viele Erdnüsse gefuttert habe, aber ich habe es immer noch nicht verstanden:

Ich habe an den Schnittstellen zwei Widerstandswerte getauscht, eine Verbindung getrennt und zwei neue Verbindungen geschaffen.
Ich habe also genau das gemacht was eine Zeit lang Kosmos gemacht hat.

Aber warum?

1. Weil sich die Architektur der Prozessoren von 16 auf 32 bit geändert hat oder
2. Weil neuere Betriebssysteme ohne Änderung an der Schnittstelle nix mehr mit der Schnittstelle anfangen konnten.

Letztlich ist die Schnittstelle von Kosmos nur eine Paralelle LPT Schnittstelle wie sie früher in jedem Drucker eingebaut war.
Das Ding wird mit einem paralellem Schnittstellenkabel an die LPT1 des PC`s angeschlossen genau da wo früher vor USB jeder Drucker angeschlossen wurde.
Die alten Drucker haben mit neuen Treibern an mehreren aufsteigenden Betriebssystemen funktioniert ohne das man daran rumlöten musste.

viele Grüße

Rolf
Kosmos Spiele mit Radio, Kosmos Elektronik Junior, Kosmos Radio Elektronik 100, Kosmos Radio Elektronik 101, Kosmos Ü3, Kosmos XN3000, Kosmos Elektronik Profi, Schuco Profi Lab
Benutzeravatar
meiseAC
 
Beiträge: 363
Registriert: 25. Mär 2010, 12:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon wolfgang » 4. Mär 2012, 21:42

Mir ist auch nicht klar, warum ein Umbau stattgefunden hat.

Ich habe mal aus den vorhandenen Bilder versucht den Zweck zu rekonstruieren. Soweit ich vermute, wird ein Kanal invertiert. Rolf kannst Du das noch mal vergleichen? Eine solche Änderung hätte definitiv nicht mit Soft- oder Hardwarewechsel zu tun.

Gruß
Wolfgang
wolfgang
 
Beiträge: 131
Registriert: 14. Apr 2010, 11:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon ChrisH » 5. Mär 2012, 12:15

Hallo,

der Tipp von Rolf war gut: "R18 - die Spassbremse" :ausflipp:

Nun geht es nämlich !!!!!!!!!!!!! Messergebnisse am PC.
Aber bitte fragt mich nicht wegen der Schnittstellentreiber und Einstellungen -
das weiss ich jetzt aus dem Stehgreif auch nicht mehr :lach:
Ne ehrlich, das muss ich erst noch mal alles in Ruhe aufrollen. Habe meinen Testaufbau
angeschalten, KOSMOS-Schnittstelle mit Strom versorgt, Rechner hochgefahren (WIN XP),
LAB001 gestartet und einen Nullabgleich gemacht. LAB002, am Poti drehen und die Zeiger
bewegen sich. Ja der Tag ist gerettet und ich habe noch viel vor.....

zeigerausschlagende Grüße, ChrisH

Rechner: AMD Sempron 2200 auf ASRock Mainboard (ca. 2008)
WIN XP: einwandfrei ohne weitere Portzuweisungen (LPT1).
WIN 98: einwandfrei ohne irgendwelche Einstellungen an LPT1.

Bild
Versuchsaufbau: praktischer Rechner mit WIN98, WIN2000 & WIN-XP multiboot
Bild
Aufbau für LAB001: Anzeige der Spannung am Poti, angeschlossene KOSMOS-Schnittstelle
Bild
Anzeige LAB001 der Spannung am Poti.
Benutzeravatar
ChrisH
 
Beiträge: 430
Registriert: 2. Feb 2011, 19:18
Wohnort: Velden/Vils

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon meiseAC » 5. Mär 2012, 15:14

Hallo ChrisH

Ich fürchte die Ehre gebührt alleine Wolfgang der mich per PM gefragt hat ob ich möglicherweise vergessen habe den R18 auszulöten.
Nachdem ich das gelesen hatte dämmerte mir etwas und ich habe dir geschrieben knipps doch mal R18 einseitig ab. :mrgreen:

Mir war in dem Moment klar das ich vergessen habe diesen R18 auszulöten. :wut: :angry:

viele Grüße

Rolf
Kosmos Spiele mit Radio, Kosmos Elektronik Junior, Kosmos Radio Elektronik 100, Kosmos Radio Elektronik 101, Kosmos Ü3, Kosmos XN3000, Kosmos Elektronik Profi, Schuco Profi Lab
Benutzeravatar
meiseAC
 
Beiträge: 363
Registriert: 25. Mär 2010, 12:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon wolfgang » 5. Mär 2012, 15:41

Hallo ChrisH,

schön das Du Erfolg mit der Schnittstelle hattest. Ich bin gespannt auf weitere Bilder und Versuche. Mich intessiert, ob die Software nur für alte Erinnerungen/Retro usw. gut ist, oder auch heute noch einigermaßen brauchbar. Dann könnte man über Kauf oder auch Selbstbau nachdenken. Das wichtigste Teil, der A/D-Wandler ist bei ebay noch zu haben (aus Übersee).

Gruß
Wolfgang
wolfgang
 
Beiträge: 131
Registriert: 14. Apr 2010, 11:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon FrankR » 5. Mär 2012, 17:29

Hallo an alle in diesemThread -
erstmal Glückwunsch zur nun lauffähigen Schnittstelle!

Wie sieht es eigentlich mit der Dokumentation der Schnittstelle aus? Ich meine damit speziell, welches Protokoll wird zwischen dem Schnittstellenbaustein und der Eingabeschnittstelle des PC gefahren, welche Daten/Informationen werden ausgetauscht, welche Pins werden wie verschaltet usw.

Da hier entweder die COM- bzw. die LPT-Schnittstelle verwendet wird, dürfte dies nicht allzu kompliziert sein. Wenn man diese Informationen alle hat, dann dürfte es auch möglich sein, eine eigene Software - entworfen nach eigenen Bedürfnissen - zu programmieren.

Oder gibt es sogar einen Treiber bzw. (noch besser!) eine API, die man für eine eigene Software benutzen könnte?

FrankR
FrankR
 
Beiträge: 318
Registriert: 17. Jan 2012, 03:33
Wohnort: Berlin

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon ChrisH » 5. Mär 2012, 19:45

Hallo Frank,

das Problem ist ja, das es zu der Schnittstelle keine Beschreibung o.Ä. gibt. 1993 steckte der User seinen Drucker an LPT1 an und er funktionierte. Da musste er auch nicht wissen, wiso und warum :lol: KOSMOS hat sich da auf ein paar allgemeine Zeilen beschränkt aber weiter nichts.
In der "Kosmos.ini", die die Software im Verzeichnis "Windows" anlegt, fand ich das: "Treiberversion=V3.0-01, 15.6.1995, ©Abacus". Die KosmoLab-Software (nennt sich WinLab Pro - Runtime) wurde wohl hergestellt/vertrieben von: "Firma H. Scharnagl, W-8481 Parkstein, Fax 09602-5722". Die Firma findet sich heute unter "Industriesoftware Scharnagl, 92711 Parkstein, Schulstrasse 7". Mehr ist auch nicht rauszufinden. Bei Interesse kann ich die Platine mal mit Nahaufnahme ablichten, damit man den Aufbau erkennen kann.

Hier habe ich noch etwas Interessantes in einem anderen Forum gefunden:

"Das Interface besteht aus einem 8-Bit-Wandler, einem Meßverstärker, der die Messung negativer Spannungen ermöglicht und Optokopplern zwischen Interface und Computer. Der Optokoppler trennt den PC galvanisch vom Versuchsaufbau. Das Interface wandelt die analogen Werte in digitale um. Das Kosmolab verarbeitet die Daten zu Meßergebnissen und stellt sie auf dem Bildschirm dar.
Das Interface hat 4 Analogeingänge (IN1 bis IN4), die Spannungen von -10V bis +10V verarbeiten können. Der Eingangswiderstand beträgt ca. 2MOhm. Zwei Transistorausgänge (OUT1 und OUT2) stehen zur Verfügung. Die Schaltausgänge sind über Optokopplern vom PC getrennt. Von den beiden Ausgangstransistoren (bis 2 mA belastbar) sind Emitter (E) Und Kollektor (C) herausgeführt. Die Auflösung des Interfaces beträgt ca. 0,08V und die Toleranz liegt bei ca. 5%. Die Stromversorgung erfolgt durch zwei 9V Batterien."


Grüße, ChrisH
Benutzeravatar
ChrisH
 
Beiträge: 430
Registriert: 2. Feb 2011, 19:18
Wohnort: Velden/Vils

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon FrankR » 5. Mär 2012, 20:40

Mich interessierte nur die sofware-technische Seite der Schnittstelle. Also: was wir an Daten zwischen KOSMOS-Interface und PC übetragen(und umgekehrt). Und dann höchstens noch die Pins, die tatsächlich miteinander verbunden sind. Wenn man das weiß, dann sollte man eigentlich eine eigene Software darauf aufsetzen können! Alles was zwischen KOSMOS-Schaltung und KOSMOS-Schnittstelle bzw. in der KOSMOS-Schnittstelle selbst passiert ist hier zunächst uninteressant!

Habe ich das bisher falsch verstanden, daß die Schnittstelle auch an der seriellen COM-Schnittstelle des PC arbeitet? Zuletzt war hier nur noch von der parallelen LPT-Schnittstelle die Rede.

Bei der COM-Schnittstelle wäre z.B. auch noch wichtig, welches Hardware-Protokoll gefahren wird, also: welche Seite schaltet wann welche Pins ein bzw. aus, wie sind die Pins miteinander verschaltet (DCD, DTR, DSR, RTS, CTS, usw.), Anzahl Startbits, etc., etc. ...

Ich hatte nur deshalb danach gefragt, weil Wolfgang danach fragte, ob die Sofware noch heutigen(?) Ansprüchen genügen würde. Da kam ich darauf, daß diese sich einfach entsprechend eigenen Bedürfnissen selbst schreiben läßt. Wenn man denn weiß, was auf der PC-Schnittstelle so abkommt ...

PS:
ChrisH hat geschrieben:1993 steckte der User seinen Drucker an LPT1 an und er funktionierte.


Aber wehe, er hatte einen seriellen Drucker, der über COM angeschlossen werden mußte. Dann war tagelange Arbeit angesagt! Ich besitzte ein ganzes Buch darüber - es beschäftigt sich ausschließlich damit, serielle Drucker über eine COM-Schnittstelle (gemäß RS-232 - ein Standard, der eigentlich nur für den Anschluß von Modems entwickelt wurde) anzuschließen. Meistens funktionierte zunächst garnichts ...

Gruß
Frank
FrankR
 
Beiträge: 318
Registriert: 17. Jan 2012, 03:33
Wohnort: Berlin

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon wolfgang » 5. Mär 2012, 22:03

Hallo Frank,

das Interface benutzt den seriellen AD-Wandler ADC0838CCN. Schau doch mal im Datenbaltt nach, da sollte eigentlich alles enthalten sein.

http://www.alldatasheet.com/datasheet-p ... 38CCN.html

Wenn ich mir die Platine anschaue, sieht das stark nach Parallelschnittstelle aus, die verwendet wird. Da aber nur insgesamt 6 Optokoppler zur Verfügung stehen, wovon 2 als Ausgänge verwendet werden, scheint wohl die Datenübertragung seriell zu erfolgen.

Gruß
Wolfgang
wolfgang
 
Beiträge: 131
Registriert: 14. Apr 2010, 11:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon FrankR » 5. Mär 2012, 23:12

Hi Wolfgang,

ich habe es mir noch nicht im Detail angesehen - aber dieses Datenblatt (26 Seiten) scheint Gold wert zu sein!
Toller Hinweis - Danke!

Frank
FrankR
 
Beiträge: 318
Registriert: 17. Jan 2012, 03:33
Wohnort: Berlin

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon ChrisH » 10. Mär 2012, 17:05

Hallo,

auf alle Fälle ist abschliessend zu sagen: die Schnittstelle nebst Zubehör funktionieren und es macht richtig
Spaß, damit zu arbeiten. Für den Aufbau und die Versuche werde ich einen neuen Thread anlegen.

Danke noch an alle, die mich mit Rat und Tat unterstützt haben. Nun hoffe ich, das der "Nächste Besitzer"
eines XN HiTec PC dann durch Google und Co. über unser schönes Forum "stolpert" - und hier wirklich
nützliche Dinge und Hilfe zu lesen bekommt :thumb:

Grüße, ChrisH
Benutzeravatar
ChrisH
 
Beiträge: 430
Registriert: 2. Feb 2011, 19:18
Wohnort: Velden/Vils

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon wolfgang » 12. Mai 2012, 02:53

Hallo,

ich habe versucht, die Software auf einem Windows NT4 SP4 System zu installieren. NT hat dabei nicht gemeckert. Allerdings hat es doch mehrerer Anläufe benötigt, bis es richtig geklappt hat:

1.Veruch

Für die Entwicklung des Installationsprogrammes hat man sich wirklich keine Mühe gegeben. Irgendwann öffnet es mehrere Fenster, in denen verschiedene Programme installiert werden. Plötzlich ist das Fenster des Installationsprogrammes verschwunden. Man kann raten, ob die Installation erfolgreich war. Auf wechselt die Installation nicht von der ersten zur zweiten Diskette, sondern nach Installation der ersten, muss das Installationsprogramm auf Diskette 2 separat gestartet werden.

2.Veruch

Nach der ersten Installation fehlen mehrere Messprogramme. Diese sind einfach nicht installiert worden.

3.Veruch

Jetzt sind alle Programme vorhanden, aber ein Treiber wird von der Software als fehlerhaft erkannt. Als Ergebnis kann der Cursor nicht genutzt werden.

4.Veruch

Jetzt sind auch die Treiber vorhanden. Alles scheint zu funktionieren.

Gruß
Wolfgang
wolfgang
 
Beiträge: 131
Registriert: 14. Apr 2010, 11:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon FrankR » 12. Mai 2012, 10:50

Hi Wolfgang!

Interessante Installationsbeschreibung!
Besonders bei "Versuch 1" weiß man nicht, ob man lachen oder fluchen soll: Von Disk 1 und Disk 2 separat zu installieren ohne dazu aufgefordert worden zu sein ... usw.

Aber was genau hast Du von Versuch 1 zu Versuch 4 jeweils anders gemacht? Das wäre vielleicht noch sehr interessant zu erfahren! Hast Du jeweils den jeweils vorhergehenden Installationsversuch komplett gelöscht? Und dann irgendwelche Einstellungen geändert? Oder über den vorhergehenden Versuch nochmals drüber installiert?

Vielleicht kannst Du ja ein Kochrezept für eine erfolgreiche Installation angeben? (Falls es dies überhaupt gibt!!!)

Gruß
Frank
FrankR
 
Beiträge: 318
Registriert: 17. Jan 2012, 03:33
Wohnort: Berlin

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon ChrisH » 12. Mai 2012, 11:28

Hallo Leute,

...mann darf erstens nicht vergessen, dass wir von Software von 1993 (oder früher) reden und ein Floppylaufwerk nun mal Standard war. Ich weiss noch von einigen anderen Programmen und Spielen, dass es halt (aus heutiger Sicht) echt umständlich war zu installieren. Zudem war der Arbeitsspeicher meist nur 1 MegaByte gross ;-) Hat mal wer von Euch Windows 3.11 von den 19 Disketten installiert :lach:

Ich habe den Inhalt beider Disketten in ein Verzeichniss auf meinem Stick kopiert. Da lief es recht flott. Es fehlten auch keine Programme (m.E. werden einige Dateien überschrieben). Und bei dem Update (Zip-Datei) werden ein paar Programmdateien nochmals mit neuerem Stand überschrieben. Am Besten dann das ganze (installierte) Verzeichniss sichern.

Grüße, Christian
Benutzeravatar
ChrisH
 
Beiträge: 430
Registriert: 2. Feb 2011, 19:18
Wohnort: Velden/Vils

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon wolfgang » 13. Mai 2012, 20:44

Hallo,

nach dem ersten Versuch habe ich noch die Daten auf der Festplatte entfernt. Ab Versuch drei habe ich nur noch die Installation erneut laufen lassen. In Ermangelung an ein Diskettenlaufwerk habe ich die Installation von CD ausgeführt.

Nun ich bin auch in der Diskettenzeit groß geworden und habe diverse Systeme mit DOS, Windows, Office-Pakt usw. über Disketten installiert. Windowsprogramme waren da normalerweise recht problemlos. Tricki waren meistens DOS-Programme, vorzugsseise Spiele, die einen hohen Speicherbedarf hatten. Da hatte ich einige spezielle Startdisketten, die für besondere Programme eine minimale Auswahl von Treibern starteten.

Aber auch aus dieser Zeit war ich irgendwie gewohnt, dass ein Diskettenwechsel ohne erneutes Starten der Installtion möglich war und zum Abschluss der Installtion irgend eine Fertig- oder Erfolgreichmeldung kam.

Gruß
Wolfgang
wolfgang
 
Beiträge: 131
Registriert: 14. Apr 2010, 11:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon wolfgang » 14. Mai 2012, 10:30

Hallo Chris,

bei der Installation sind vier neue Programmgruppen eingerichtet worden. in den ersten beiden sind die Programme zu sehen. Die Dritte und Vierte sind leer. Ist das bei Dir auch so?

Gruß
Wolfgang
wolfgang
 
Beiträge: 131
Registriert: 14. Apr 2010, 11:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon naicheben » 30. Dez 2012, 19:57

Hallo Wolfgang,
bei mir sieht das genau so aus. Die Software installiert sich bei mir unter Win98 problemlos. Ich habe dann einen pseudo Standard-Drucker installiert und die Soft startet ohne Probleme zu melden. Auch wenn ich das Interface gar nicht angeschlossen habe.....
Ein Originalkabel habe ich nicht. Mein Kabel ist 1:1 Männchen-Männchen. Ist das richtig?
Leider habe ich keinen BiDirectional-Mode für den LPT im BIOS, nur EPP und ECP. Funktioniert das bei Euch mit EPP 1.7?

Gruß,
Ingmar
Kosmos HiTec mit PC-Interface
naicheben
 
Beiträge: 10
Registriert: 30. Dez 2012, 16:24

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon ChrisH » 31. Dez 2012, 10:27

Hallo Ingmar,

das Kabel ist Stecker/Stecker, seriell. Habe es mir im Auktionshaus besorgt da es im ersten HiTec fehlte. Die Schnittstelle stand auch
standardgemäss auf EPP das hat alles funktioniert. Die Software läuft auch ohne angeschlossener Karte (zeigt natürlich aber nichts an).
Hast Du Deine Platine schon umgebaut? Und den neuen Softwarestand (siehe meinen Beitrag)?

Wolfgang, ich habe mir sagen lassen, dass KOSMOS ursprünglich ein Update mit noch mehr Messmöglichkeiten vorhatte. Daher gab es (bzw.
werden immernoch eingerichtet) vier Programmgruppen. Ich habe die zwei leeren Gruppen gelöscht. Die Software lässt sich auch problemlos
von einem Stick oder von CD installieren (in Mangel eines Floppylaufwerkes). Und die Software lief bei mir unter verschiedenen WIN-Versionen.
Allerdings eben mit Softwareupdate und Platinenumbau. Vorher ging es nicht.

Grüße, Christian
Benutzeravatar
ChrisH
 
Beiträge: 430
Registriert: 2. Feb 2011, 19:18
Wohnort: Velden/Vils

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon naicheben » 4. Jan 2013, 21:55

Ja, die Platine habe ich umgebaut. Ich habe selber nur die Version 1.0 auf Diskette. Für Google bin ich scheinbar zudoof, zumindest finde ich das Update nicht.

Allerdings glaube ich, dass ich noch ein Problem mit dem Parallelport habe. Ich habe mal ein VisualBasic installiert und ein Testprogramm für den Parallelport übersetzt, leider sind bei mir die Datenleitungen immer high, egal was ich an den Parallelport ausgebe.....

EDIT: Die Kommunikation zwischen PC und 8Bit-AD-Wandler geschieht über Microwire, ein serielles Protokoll von National Semiconductors. TTL/MOS kompatibel. Die Zeit für eine Wandlung beträgt 32µs. Also maximal 31250 Samples/Sekunde. Ich könnte mir vorstellen, dass mein PC dafür zu schnell ist.
Ich habe mal die LPT-Pins auf der Platine verfolgt:
D0 geht über R16 an den Optokoppler - Der Emitter des Transistors vom Optokoppler geht über R14 an GND und an DIn vom ADC0838
D1 geht über R17 an den Optokoppler - Der Emitter des Transistors vom Optokoppler geht über R13 an GND und an CLK vom ADC0838
D3 geht über R21 an den Optokoppler - Der Emitter des Transistors vom Optokoppler geht über R15 an GND und an /CS vom ADC0838
D4 geht über R24 an den Optokoppler - Der Emitter des Transistors vom Optokoppler geht an Out2-E und der Collector über R22 an Out2-C
D5 geht über R25 an den Optokoppler - Der Emitter des Transistors vom Optokoppler geht an Out1-E und der Collector über R23 an Out1-C
D2 geht über R20 an LPT-Pin15(STATUS) und an den Collector vom Optokoppler - D0ut vom ADC0838 geht über R19 an den Optokoppler

Der ADC ist im Single Ended Modus (SGL-/DIF=1)
V+, SARS und /SE sind unbeschaltet.
VREF und Chanel5 liegen auf +5V
Kosmos HiTec mit PC-Interface
naicheben
 
Beiträge: 10
Registriert: 30. Dez 2012, 16:24

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon naicheben » 15. Jan 2013, 16:01

Zum Kommunikationsprotokoll:
/CS vom ADC wird auf LOW geschaltet.
CLK taktet mit der steigenden Flanke die Daten von DIn in das MUX-Adressregister. Dabei wird die erste gefundene "1" als Startbit betrachtet. Dann kommt SGL/NDIF=1 (SinGLe-ended/not-Differential). Dann ODD/SIGN, also ob es ein gerader oder ungerader Kanal ist. Dann SELECT1 (ist LOW für Channel 0-3). Dann SELECT0 (ergibt mit ODD/SIGN die Adresse für den gewünschten Kanal)
Wenn das Startbit nach 4 Takten eingelesen ist, startet die A/D Wandlung. Wenn die fertig ist, wird auf die fallende Flanke von CLK über DO (MSB zu erst) der Kanal ausgegeben.
/CS muss dann auf HIGH und wieder auf LOW gehen, damit ein anderer Kanal ausgewählt werden kann.
Kosmos HiTec mit PC-Interface
naicheben
 
Beiträge: 10
Registriert: 30. Dez 2012, 16:24

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon naicheben » 15. Jan 2013, 17:04

Ich habe jetzt auf einem Windows XP Rechner die Software installiert und starte das LAB im Kompatibilitätsmodus (Windows95). Er findet nicht immer auf Anhieb das Interface. Nullabgleich (LAB-000) geht nicht. Ebensowenig LAB-001. Aber mit LAB-005 kann man LEDs zum leuchten bringen über Out1 und Out2, das geht bei mir. Also der Zugriff auf den Parallelport habe ich schon mal. Ich suche mal nach einer Softwarebremse für den LPT....

EDIT: Softwarebremse habe ich keine gefunden. Alles alter Kram und eher für Spiele.
Meine Zeiger zittern immer zwischen 0V und Vollausschlag (mal nach -10V, mal nach +10V), ein Kalibrieren funktioniert nicht.
Kosmos HiTec mit PC-Interface
naicheben
 
Beiträge: 10
Registriert: 30. Dez 2012, 16:24

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon naicheben » 15. Jan 2013, 19:35

Erfolg!
Auf einem EPIA M10000B (Nehemia) Board mit 512MB-RAM funktioniert es. Allerdings musste ich mir einen Adapter zusammenlöten, der die Pins vom LPT auf das Interface "dreht". Es sind zwei männliche Stecker, pin1 auf pin1 usw.
Mit besagtem Adapter findet der "große AthlonX2-4600+" WinXP-Rechner das Interface nicht zuverlässig, aber immerhin geht Lab-005 (LEDs schalten). Da es mit dem lahmen Nehemia geht, schätze ich dass es etwas mit dem Timing am Parallelport zu tun hat.

Danke Euch noch mal für die Unterstützung!
Kosmos HiTec mit PC-Interface
naicheben
 
Beiträge: 10
Registriert: 30. Dez 2012, 16:24

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon meiseAC » 15. Jan 2013, 21:11

Hallo naicheben

Schön das es nun klappt. Darf ich dir trotzdem einen Knopf vorstellen der sich über jeden deiner Beiträge oben Rechts in der Ecke befindet?
Mit diesem kan man seinen Beitrag ohne zeitliche Begrenzung ändern und ergänzen. :lach:
Die Nutzung dieser Funktion erspart 4 Beiträge hinereinander und sorgt für die nötige Übersicht.


viele Grüße


Rolf
Kosmos Spiele mit Radio, Kosmos Elektronik Junior, Kosmos Radio Elektronik 100, Kosmos Radio Elektronik 101, Kosmos Ü3, Kosmos XN3000, Kosmos Elektronik Profi, Schuco Profi Lab
Benutzeravatar
meiseAC
 
Beiträge: 363
Registriert: 25. Mär 2010, 12:00

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon naicheben » 15. Jan 2013, 21:55

Hallo Rolf,
der Ändern-Knopf hat aber den Nachteil (zumindest bei allen anderen Foren in denen ich aktiv bin) dass keine Sau mitbekommt, dass in dem Thread etwas neues beigetragen wurde. Ich habe darum in voller Absicht gehandelt, als ich nicht Ändern sondern Antworten gedrückt habe. :oops: Sollte das hier anders gewünscht sein oder ich falsch liege mit meiner obigen Annahme, bitte ich um kurze Info.

Schönen Abend noch,
Ingmar
Kosmos HiTec mit PC-Interface
naicheben
 
Beiträge: 10
Registriert: 30. Dez 2012, 16:24

Re: "Schnittstelle nicht gefunden" - eine Beziehungskriese

Ungelesener Beitragvon meiseAC » 16. Jan 2013, 06:56

Hallo Ingmar.

Da hast du Recht disen Nachteil hat der Knopf in der Tat.

viele Grüße

Rolf
Kosmos Spiele mit Radio, Kosmos Elektronik Junior, Kosmos Radio Elektronik 100, Kosmos Radio Elektronik 101, Kosmos Ü3, Kosmos XN3000, Kosmos Elektronik Profi, Schuco Profi Lab
Benutzeravatar
meiseAC
 
Beiträge: 363
Registriert: 25. Mär 2010, 12:00


Zurück zu VERSUCHSLABOR UND EXPERIMENTE

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron